Frama-C Bug Tracking System

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002462Frama-CPlug-in > clangpublic2019-07-04 19:492019-07-05 14:12
Reporterainne26 
Assigned Tovirgile 
PriorityhighSeveritymajorReproducibilityalways
StatusassignedResolutionopen 
PlatformOSwindowsOS Versionwindows 10
Product Version 
Target VersionFixed in Version 
Summary0002462: frama-clang failed to install
DescriptionHi, I'm trying to install the Frama-Clang plugin on windows 10 following the instruction on the website. But the command $ ./configure checking for frama-c-gui... yes checking for Makefile.config.in... yes frama_clang... yes checking for g++... g++ checking whether the C++ compiler works... yes checking for C++ compiler default output file name... a.exe checking for suffix of executables... .exe checking whether we are cross compiling... no checking for suffix of object files... o checking whether we are using the GNU C++ compiler... yes checking whether g++ accepts -g... yes checking for camlp4o... yes checking for clang... clang checking for clang++... clang++ checking for llvm-config... llvm-config checking for D:\llvm-project-master\llvm\build\Debug/include/clang... no configure: WARNING: frama_clang disabled because clang dev headers not found. configure: frama_clang: no configure: creating ./config.status config.status: creating ./Makefile.config chmod: ./Makefile.config: new permissions are r--rw-r--, not r--r--r--` I don't know how to solve this problem, any suggestions?
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0006811)
virgile (developer)
2019-07-05 10:37

If you don't mind, I'd prefer to concentrate all discussions on this issue in the github report at https://github.com/Frama-C/Frama-C-snapshot/issues/22 . Splitting them in two places will probably not lead to the most efficient solving process.
(0006813)
ainne26 (reporter)
2019-07-05 14:12
edited on: 2019-07-05 14:12

virgile I had followed the instruction given on github but unable to resolve this issue. So, its my humble request help me to resolve this issue because I am trying to resolve it from previous 15 days and tried my best but unable to do it.

- Issue History
Date Modified Username Field Change
2019-07-04 19:49 ainne26 New Issue
2019-07-04 19:49 ainne26 Status new => assigned
2019-07-04 19:49 ainne26 Assigned To => virgile
2019-07-05 10:37 virgile Note Added: 0006811
2019-07-05 10:37 virgile Status assigned => feedback
2019-07-05 14:12 ainne26 Note Added: 0006813
2019-07-05 14:12 ainne26 Status feedback => assigned
2019-07-05 14:12 ainne26 Note Edited: 0006813 View Revisions


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker