2020-12-05 00:30 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002448Frama-CDocumentation > websitepublic2019-06-04 19:51
Reportervarosi 
Assigned Tobobot 
PrioritynormalSeverityminorReproducibilityalways
StatusassignedResolutionopen 
PlatformOSmacOSOS VersionMojave
Product VersionFrama-C 18-Argon 
Target VersionFixed in Version 
Summary0002448: frama-c installation needs dune > 1.5 package installed
DescriptionInstallation instructions here - https://frama-c.com/install-18.0-Argon.html#installing-frama-c-on-macos
Doesn't tell that dune package in spam should be > 1.5. This brakes build with strange message telling the reverse:
# Error: Version 1.5 of dune is not supported.
# Supported versions:
# - 0.0
# - 1.0 to 1.1

If you do install later package with:
opam install dune.1.9.3

Everything works just fine. So it would make life of newcomers like me easier if this is said in install instructions here:
https://frama-c.com/install-18.0-Argon.html#installing-frama-c-on-macos
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0006778

virgile (developer)

Could you provide the full opam output? Frama-C does not use dune itself. It's probably some package on which it depends that fails to install (and which may have to update its own dependencies).
+Notes

-Issue History
Date Modified Username Field Change
2019-06-04 18:34 varosi New Issue
2019-06-04 18:34 varosi Status new => assigned
2019-06-04 18:34 varosi Assigned To => bobot
2019-06-04 19:51 virgile Note Added: 0006778
+Issue History