2021-01-15 15:27 CET

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0002372Frama-CKernel > configurepublic2019-07-05 11:41
Reportersthudium@mac.com 
Assigned Tovirgile 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformMacbook ProOSOS XOS Version10.3.3
Product VersionFrama-C 16-Sulfur 
Target VersionFixed in VersionFrama-C 19-Potassium 
Summary0002372: coq and ocaml conflict
DescriptionI cannot install frame-c.

The error report says that the installed version of coq and ocaml conflict with frama-c.

See attached txt file.
TagsNo tags attached.
Attached Files
  • txt file icon install framac terminal text.txt (1,422 bytes) 2018-03-28 02:20 -
    Last login: Tue Mar 27 16:33:59 on ttys001
    Stephens-MacBook-Pro:~ sthudium$ opam install frama-c
    The following dependencies couldn't be met:
      - frama-c -> coq
      - frama-c -> frama-c-base (= 20150201 | = 20151002 | = 20160502 | = 20161101 | = 20170501)
    Your request can't be satisfied:
      - coq.8.7.0 is in conflict with frama-c.20171101
      - coq.8.7.1 is in conflict with frama-c.20171101
      - coq.8.7.1+1 is in conflict with frama-c.20171101
      - coq.8.7.1+2 is in conflict with frama-c.20171101
      - coq.8.7.2 is in conflict with frama-c.20171101
      - frama-c-base.20150201 is not available because your system doesn't comply with ocaml-version >= "4.0" & ocaml-version != "4.02.0" & ocaml-version < "4.04.0".
      - frama-c-base.20151002 is not available because your system doesn't comply with ocaml-version >= "4.0" & ocaml-version != "4.02.0" & ocaml-version != "4.02.2" & ocaml-version < "4.04.0".
      - frama-c-base.20160502 is not available because your system doesn't comply with ocaml-version >= "4.00.1" & ocaml-version != "4.02.0" & ocaml-version != "4.02.2" & ocaml-version < "4.04.0".
      - frama-c-base.20161101 is not available because your system doesn't comply with ocaml-version >= "4.02.3" & ocaml-version < "4.06".
      - frama-c-base.20170501 is not available because your system doesn't comply with ocaml-version >= "4.02.3" & ocaml-version < "4.06".
    
    No solution found, exiting
    Stephens-MacBook-Pro:~ sthudium$ 
    
    txt file icon install framac terminal text.txt (1,422 bytes) 2018-03-28 02:20 +

-Relationships
+Relationships

-Notes

~0006542

sthudium@mac.com (reporter)

I switch to an earlier version of opam "using opam switch 4.03.0".

The frama-c installation then completed.

Apparently, the latest versions of frama-c and opam are not compatible.

~0006543

virgile (developer)

Indeed, the current Frama-C version cannot be installed against OCaml 4.06. You should normally be able to compile it against OCaml 4.05, though.

~0006774

virgile (developer)

Frama-C 9.0 is compatible with all released OCaml version up to 4.07
+Notes

-Issue History
Date Modified Username Field Change
2018-03-28 02:20 sthudium@mac.com New Issue
2018-03-28 02:20 sthudium@mac.com Status new => assigned
2018-03-28 02:20 sthudium@mac.com Assigned To => virgile
2018-03-28 02:20 sthudium@mac.com File Added: install framac terminal text.txt
2018-03-28 09:39 sthudium@mac.com Note Added: 0006542
2018-03-28 09:51 virgile Note Added: 0006543
2019-05-23 17:17 virgile Note Added: 0006774
2019-05-23 17:17 virgile Resolution open => fixed
2019-05-23 17:17 virgile Fixed in Version => Frama-C 19-Potassium
2019-05-23 17:18 virgile Status assigned => resolved
2019-07-05 11:41 signoles Status resolved => closed
+Issue History