Frama-C Bug Tracking System - Frama-C
View Issue Details
0000757Frama-CDocumentationpublic2011-03-17 15:232016-06-21 14:24
Reportersignoles 
Assigned Tosignoles 
PrioritynormalSeveritytweakReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionFrama-C Carbon-20110201 
Target VersionFixed in VersionFrama-C Nitrogen-20111001 
Summary0000757: mismatch between configure check and INSTALL requirements for ocamlgraph version
Descriptionconfigure checks an exact version number for ocamlgraph, while INSTALL says >=.
Additional InformationDon't know what is the best thing to do:
- allowing >= is better, but requires that ocamlgraph is stable enough (forward compatibility). Not sure that it is the case yet :-(.
- allowing only = is simpler, but much less flexible for users.
TagsNo tags attached.
Attached Files

Notes
(0004821)
signoles   
2014-02-12 16:59   
Fix committed to stable/neon branch.

Issue History
2011-03-17 15:23signolesNew Issue
2011-03-17 15:23signolesStatusnew => assigned
2011-03-17 15:23signolesAssigned To => signoles
2011-03-17 15:23signolesStatusassigned => confirmed
2011-03-17 15:24signolesSummarymismatch between configure check and INSTALL for ocamlgraph => mismatch between configure check and INSTALL requirements for ocamlgraph version
2011-03-25 10:06svn
2011-03-25 10:06svnStatusconfirmed => resolved
2011-03-25 10:06svnResolutionopen => fixed
2011-10-10 14:13signolesFixed in Version => Frama-C Nitrogen-20111001
2011-10-10 14:14signolesStatusresolved => closed
2013-12-19 01:12signolesSource_changeset_attached => framac master 9726bed9
2014-02-12 16:54signolesSource_changeset_attached => framac stable/neon 9726bed9
2014-02-12 16:59signolesNote Added: 0004821
2014-02-12 16:59signolesStatusclosed => resolved
2016-06-21 14:11signolesCategoryDocumentation => Documentation > ACSL
2016-06-21 14:24signolesCategoryDocumentation > ACSL => Documentation