Frama-C Bug Tracking System - Frama-C
View Issue Details
0002448Frama-CDocumentation > websitepublic2019-06-04 18:342019-06-04 19:51
Frama-C 18-Argon 
0002448: frama-c installation needs dune > 1.5 package installed
Installation instructions here - Doesn't tell that dune package in spam should be > 1.5. This brakes build with strange message telling the reverse: # Error: Version 1.5 of dune is not supported. # Supported versions: # - 0.0 # - 1.0 to 1.1 If you do install later package with: opam install dune.1.9.3 Everything works just fine. So it would make life of newcomers like me easier if this is said in install instructions here:
No tags attached.
Issue History
2019-06-04 18:34varosiNew Issue
2019-06-04 18:34varosiStatusnew => assigned
2019-06-04 18:34varosiAssigned To => bobot
2019-06-04 19:51virgileNote Added: 0006778

2019-06-04 19:51   
Could you provide the full opam output? Frama-C does not use dune itself. It's probably some package on which it depends that fails to install (and which may have to update its own dependencies).